No way to downgrade from Scylla 5.1?

Hi,

I tried to downgrade from Scylla 5.1 to 5.0. As there already are ME sstables written, I tried to start the scylla 5.1 nodes with “sstable_format: md”. But unfortunetaly I am getting an error when starting scylla back up:

scylla[3148642]: [shard 0] init - Startup failed: std::runtime_error (Feature ‘ME_SSTABLE_FORMAT’ was previously enabled in the cluster but its support is disabled by this node. Set the corresponding configuration option to enable the support for the feature.)

Should this setting simply prevent scylla from writing me-sstables, but still be able to read them?

Is there any other way to downgrade back to 5.0?

regards,
Christian

I’d try to fix the problem with 5.1 and stay on 5.1 if possible.

Since with new sstables already in cluster you really have just 2 options

  1. stream whole DB from 5.1 to other DB using CQL (using one of migration methods)
  2. try to side-load the new sstables with (5.1) sstableloader against old DB (this might be tricky if collections are used, resp. where write timestamps will not be used)

hth
L

I see. I guess I won’t revert back then. My expectation was that downgrading using the sstable setting should be possible.
But I guess I have to remember to specify that right with the deployment to avoid sstable upgrades.

Thanks