I tried to install the Scylla DB on my ubuntu 23.04. I followed the official documentation to install it but facing issues in the last command. The issue is given below:
The following packages have unmet dependencies:
scylla-tools-core : Depends: python (>= 2.7) but it is not installable or
python2 but it is not installable
E: Unable to correct problems, you have held broken packages.
When I searched on the Internet, it shows that Scylla DB will run on Python3. but I am getting error in this and Even not able to install python 2 on the latest ubuntu.
Can someone help to resolve the issue?
Which version are you trying to install? We have moved to python3 in a recent release.
I tried to install ScyllaDB 5.2 version (from here: https://www.scylladb.com/download/#open-source). scylla-tools-core package was asking for previous python version.
Will scylla-tools-core package work on python3 in recent release?
Note: Using this way only, I was able to use scylla on Ubuntu 22.04 because Python2 package was there unlike Ubuntu 23.04
Looks like Python 3 support is only coming in the next release (5.4). In the meanwhile please use an OS which still has Python 2 available. See our OS compatibility page for guidance.