High Compaction at peak


I want to know how to adjust compaction_static_shares parameter according to the load. We are experiencing high compaction running at peak read and latency increases to 5s. Help us to understand the above parameter.

Scylla version 5.2

Thank you

usually, we set compaction_static_shares to 100 to minimize impact. 1k is the maximum value. do you have monitoring set up? latency increases to that only during compaction?

1 Like