After Successfully Install ScyllaDB Enterprise on UBUNTU, we are trying to update configuration file scylla.yaml and after Saving the below configuaration, we tried to restart Scylla but getting error

# The name of the cluster. This is mainly used to prevent machines in
# one logical cluster from joining another.
cluster_name: 'Test Cluster'

# This defines the number of tokens randomly assigned to this node on the ring
# The more tokens, relative to other nodes, the larger the proportion of data
# that this node will store. You probably want all nodes to have the same number
# of tokens assuming they have equal hardware capability.
num_tokens: 256

# Directory where Scylla should store data on disk.
    - /var/lib/scylla/data

# commit log.  when running on magnetic HDD, this should be a
# separate spindle than the data directories.
commitlog_directory: /var/lib/scylla/commitlog

# seed_provider class_name is saved for future use.
# A seed address is mandatory.
    # The addresses of hosts that will serve as contact points for the joining node.
    # It allows the node to discover the cluster ring topology on startup (when
    # joining the cluster).
    # Once the node has joined the cluster, the seed list has no function.
    - class_name: org.apache.cassandra.locator.SimpleSeedProvider
          # In a new cluster, provide the address of the first node.
          # In an existing cluster, specify the address of at least one existing node.
          # If you specify addresses of more than one node, use a comma to separate them.
          # For example: "<IP1>,<IP2>,<IP3>"
          - seeds: ""

# Address or interface to bind to and tell other Scylla nodes to connect to.
# You _must_ change this if you want multiple nodes to be able to communicate!
# Setting listen_address to is always wrong.
listen_address: localhost

# Address to broadcast to other Scylla nodes
# Leaving this blank will set it to the same value as listen_address
# broadcast_address:

# port for the CQL native transport to listen for clients on
# For security reasons, you should not expose this port to the internet.  Firewall it if needed.
native_transport_port: 9042

# Uncomment to enable experimental features
# experimental: true

What’s the error? Share as many details as possible.

Scylla version 2023.1.2-0.20231001.646df23cc4b3 with build-id 367fcf1672d44f5cbddc88f946cf272e2551b85a starting ...
command used: "/usr/bin/scylla --log-to-syslog 1 --log-to-stdout 0 --default-log-level info --network-stack posix"
parsed command line options: [log-to-syslog, (positional) 1, log-to-stdout, (positional) 0, default-log-level, (positional) info, network-stack, (positional) posix
backend: linux-aio
- Creation of perf_event based stall detector failed, falling back to posix timer: std::system_error (error system:13, perf_event_op>
- Created fair group io-queue-0, capacity rate 2147483:2147483, limit 12582912, rate 16777216 (factor 1), threshold 2000
- IO queue uses 0.75ms latency goal for device 0
- Created io group dev(0), length limit 4194304:4194304, rate 2147483647:2147483647
- Created io queue dev(0) capacities: 512:2000:2000 1024:3000:3000 2048:5000:5000 4096:9000:9000 8192:17000:17000 16384:33000:33000 32768:65000:65000 65536:129000:129000 131072:257000:257000
- updated: blocked-reactor-notify-ms=1000000
nstalling SIGHUP handler
cylla version 2023.1.2-0.20231001.646df23cc4b3 with build-id 367fcf1672d44f5cbddc88f946cf272e2551b85a starting ...
nly 476 MiB per shard; this is below the recommended minimum of 1 GiB/shard; terminating.Configure more memory (--memory option) or decrease shard count (--smp option)
shutting down sighup
shutting down sighup was successful
shutting down configurables
shutting down configurables was successful
startup failed: std::runtime_error (configuration (memory per shard too low))
.1.2-0.20231001.646df23cc4b3 with build-id 367fcf1672d44f5cbddc88f946cf272e2551b85a starting ...
/bin/scylla --log-to-syslog 1 --log-to-stdout 0 --default-log-level info --network-stack posix --developer-mode=1 --cpuset 0 --lock-memory=1"

After uncomment “Cluster name” and restarting i am getting below error

Startup failed: exceptions::configuration_exception (Saved cluster name != configured name Demo cluster1)

In scylla.yaml file I uncommented the Cluster name field and getting the below error:

Startup failed: exceptions::configuration_exception (Saved cluster name != configured name Demo cluster1)

Could you please tell me why it not working ??

Please have a look .