# Restoring a backup with Scylla Manager and sctool restore authentication

**URL:** https://forum.scylladb.com/t/restoring-a-backup-with-scylla-manager-and-sctool-restore-authentication/3155
**Category:** ScyllaDB
**Tags:** scylla-manager, backup-restore, authentication
**Created:** [November 10, 2024, 9:54am UTC](https://forum.scylladb.com/t/restoring-a-backup-with-scylla-manager-and-sctool-restore-authentication/3155 "2024-11-10T09:54:43Z")
**Posts on this page:** 1
**Page:** 1

<div class="post-metadata">

### Author: ![Guy](https://sea2.discourse-cdn.com/flex016/user_avatar/forum.scylladb.com/guy/32/9_2.png) [@Guy](https://forum.scylladb.com/u/Guy)
#### Post date: [November 10, 2024, 9:54am UTC](https://forum.scylladb.com/t/restoring-a-backup-with-scylla-manager-and-sctool-restore-authentication/3155/1 "2024-11-10T09:54:43Z")

</div>

> [@](#):
>
> [**Originally from the User Slack**](https://scylladb-users.slack.com/)
> 
> ![Ishaan_Raghav](https://us1.discourse-cdn.com/flex016/uploads/scylladb/original/2X/9/96f09dbac42261d3f4414422cd1a9ed37d2347f3.png) **@Ishaan\_Raghav:**  **Query 1:**  
> I am trying to restore data from a backup using scylla-manager and `sctool restore` command  
> • I restored the schema first and then restarted my db nodes as suggested in the doc.  
> • Next when I run restore with `--restore-tables` , I get the id of the process  
> • When I check the progress i see this error
> 
> ```auto
> Status: ERROR (restoring backed-up data)
> Cause: not restored bundles [4654]: restore batch: call load and stream: giving up after 10 attempts: agent [HTTP 500] Failed to load new sstables: std::runtime_error (send_meta_data: got error code=-1 from node=<IP of scylla-node>)
> 
> ```
> 
> Can someone please suggest me where I am going wrong?
> 
> **Query2:**  
> How to provide authentication in `sctool restore`? Currently I am testing with `AllowAllAuthenticator` but please suggest how to do it with password set?
> 
> ![Felipe_Cardeneti_Mendes](https://us1.discourse-cdn.com/flex016/uploads/scylladb/original/1X/233a9d524fbc97e39f08633c16b3dd2575d1d1f4.jpeg) **@Felipe\_Cardeneti\_Mendes:** 1. Something happened causing load and stream to fail, maybe ENOSPC, best to check the node logs to assess it.  
> 2. You specify it in `sctool cluster`
