# \[RELEASE\] ScyllaDB 6.0.2

**URL:** <https://forum.scylladb.com/t/release-scylladb-6-0-2/2368>\
**Category:** Release Notes\
**Tags:** open-source, open-source-release, open-source-6-0\
**Created:** [July 29, 2024, 1:43pm UTC](https://forum.scylladb.com/t/release-scylladb-6-0-2/2368 "2024-07-29T13:43:35Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![tzach](https://sea2.discourse-cdn.com/flex016/user_avatar/forum.scylladb.com/tzach/32/172_2.png) [@tzach](https://forum.scylladb.com/u/tzach)\
**Post date:** [July 29, 2024, 1:43pm UTC](https://forum.scylladb.com/t/release-scylladb-6-0-2/2368/1 "2024-07-29T13:43:35Z")

</div>

The ScyllaDB team announces ScyllaDB Open Source 6.0.2, a bugfix patch release of the ScyllaDB [6.0](https://forum.scylladb.com/t/release-scylladb-6-0/2143/2) stable branch. ScyllaDB Open Source 6.0.2, like all past and future 6.x.y releases, is backward compatible and supports [rolling upgrades](https://docs.scylladb.com/upgrade/upgrade-opensource/upgrade-guide-from-5.x.y-to-5.x.z/).

Users are encouraged to upgrade to 6.0.2.

Related links:

- [ScyllaDB Open Source 6.0.0](https://forum.scylladb.com/t/release-scylladb-6-0/2143/2)
- [Get ScyllaDB Open Source](https://www.scylladb.com/download/open-source/) - AWS AMI, GCP Docker, binary packages and unified installer
- [ScyllaDB Web Installer for Linux](https://docs.scylladb.com/stable/getting-started/install-scylla/scylla-web-installer.html) (all releases)
- [Upgrade from ScyllaDB Open Source 6.x.y to Scylla Open Source 6.x.z](https://opensource.docs.scylladb.com/stable/upgrade/upgrade-opensource/upgrade-guide-from-6.x.y-to-6.x.z.html)
- [Upgrade from ScyllaDB Open Source 5.4.x to 6.0.y](https://opensource.docs.scylladb.com/stable/upgrade/upgrade-opensource/upgrade-guide-from-5.4-to-6.0/index.html)
- Please[let us know](https://github.com/scylladb/scylla/issues) if you encounter an issue.

Issue fixed in this release:

- Security: the new ScyllaDB image (GCP, AWS, Azure, Docker) includes a fix for [OpenSSH Vulnerability CVE-2024-6387](https://forum.scylladb.com/t/openssh-vulnerability-cve-2024-6387-mitigation/2257)
- Stability: Off-strategy compaction is used to make sstables conform to the compaction strategy after an operation such as repair. Off-strategy compaction for TWCS will now have less storage space overhead. [#16514](https://github.com/scylladb/scylladb/issues/16514)
- ADMIN API: using the admin REST API may lead to a crash with assertion `!\_end && !\_zc\_bufs && “Was this stream properly closed?”’ failed [#19494](https://github.com/scylladb/scylladb/issues/19494)
- Stability: Batches (as generated by the BATCH statement) are held in the system.batchlog table. As this table can accumulate a lot of tombstones, we now take steps to ensure these tombstones are purged eagerly. This is important for repair, which replays the batch log. [#19376](https://github.com/scylladb/scylladb/issues/19376)
- Packaging: Bundle cqlsh with support for “DESC SCHEMA WITH INTERNALS” [#18989](https://github.com/scylladb/scylladb/issues/18989). Also see [#19334](https://github.com/scylladb/scylladb/issues/19334) below.
- CQL: DESC does not report [CQL Table Extensions](https://opensource.docs.scylladb.com/stable/cql/cql-extensions.html)[#19334](https://github.com/scylladb/scylladb/issues/19334)
- Stability: chunked\_vector::reserve\_partial does not work as documented if size \> max\_chunk\_capacity() [#19254](https://github.com/scylladb/scylladb/issues/19254)
- CQL: Disabling tablets using ALTER KEYSPACE should be forbidden [#18795](https://github.com/scylladb/scylladb/issues/18795). This was already non supported, but now blocked in the CQL level.
- Performance: Statements such as SELECT count(\*) use an internal map-reduce service to parallelize the query. ScyllaDB no longer does so for single-partition queries as they don’t benefit from it. [#19349](https://github.com/scylladb/scylladb/issues/19349)
- Stability: Failed to add node in parallel [#19523](https://github.com/scylladb/scylladb/issues/19523)
- Stability: hinted handoff: Scylla may initialize endpoint managers for invalid hint directories [#19172](https://github.com/scylladb/scylladb/issues/19172)
- Stability: init - Startup failed: std::runtime\_error (Failed to mark node as alive in 30000 ms …). The root cause is a node booting in gossip topology waits until all NORMAL nodes are UP. If we removed a different node just before, the booting node could still see it as NORMAL and wait for it to be UP, which would time out and fail the bootstrap. [#17526](https://github.com/scylladb/scylladb/issues/17526)
- Topology Update: Scylla allows replacing a node in one dc/rack with a node in a different dc/rack which requires full cluster repair and then cleanup all nodes. This is now blocked, and you should start a new node and decommission the old one instead. Use Replace operation in the same DC/Rack only. [#16858](https://github.com/scylladb/scylladb/issues/16858)
- Storage: ScyllaDB now use the latest [ME SSTable format](https://opensource.docs.scylladb.com/stable/architecture/sstable/sstable3/index.html) by default [#18995](https://github.com/scylladb/scylladb/issues/18995)
- Stability: tablet storage is not freed when migrating a tablet replica away [#16946](https://github.com/scylladb/scylladb/issues/16946)
- Stability: tasks: abort method hits use after free [#19304](https://github.com/scylladb/scylladb/issues/19304)
- Performance: The gossiped view update backlog is only read on shard 0 [#19232](https://github.com/scylladb/scylladb/issues/19232)
- Stability: View update generation times out during index building, wich result is redundant fake warnings. [#19261](https://github.com/scylladb/scylladb/issues/19261)
