# New instance of AWS AMI ScyllaDB 5.2.8 failed to start Scylla Server

**URL:** <https://forum.scylladb.com/t/new-instance-of-aws-ami-scylladb-5-2-8-failed-to-start-scylla-server/4850>\
**Category:** ScyllaDB\
**Tags:** error-message, configuration\
**Created:** [May 23, 2025, 11:40am UTC](https://forum.scylladb.com/t/new-instance-of-aws-ami-scylladb-5-2-8-failed-to-start-scylla-server/4850 "2025-05-23T11:40:22Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Amit\_Sahoo](https://sea2.discourse-cdn.com/flex016/user_avatar/forum.scylladb.com/amit_sahoo/32/1609_2.png) [@Amit\_Sahoo](https://forum.scylladb.com/u/Amit_Sahoo)\
**Post date:** [May 23, 2025, 11:40am UTC](https://forum.scylladb.com/t/new-instance-of-aws-ami-scylladb-5-2-8-failed-to-start-scylla-server/4850/1 "2025-05-23T11:40:22Z")

</div>

_Installation details_  
#ScyllaDB version: 5.2.8  
#Cluster size: single node  
#aws AMI:

Getting Below error:  
[shard 0] init - I/O Scheduler is not properly configured! This is a non-supported setup, and performance is expected to be unpredictably bad.  
Reason found: none of --max-io-requests, --io-properties and --io-properties-file are set.  
To properly configure the I/O Scheduler, run the scylla\_io\_setup utility shipped with Scylla.

Is it supposed to work like this?

---

<div class="post-metadata">

**Author:** ![Guy](https://sea2.discourse-cdn.com/flex016/user_avatar/forum.scylladb.com/guy/32/9_2.png) [@Guy](https://forum.scylladb.com/u/Guy)\
**Post date:** [May 25, 2025, 4:11am UTC](https://forum.scylladb.com/t/new-instance-of-aws-ami-scylladb-5-2-8-failed-to-start-scylla-server/4850/2 "2025-05-25T04:11:53Z")

</div>

You are running an old version that is no longer supported; please upgrade.  
What happens when you run the utility as the message suggests?

---

<div class="post-metadata">

**Author:** ![Amit\_Sahoo](https://sea2.discourse-cdn.com/flex016/user_avatar/forum.scylladb.com/amit_sahoo/32/1609_2.png) [@Amit\_Sahoo](https://forum.scylladb.com/u/Amit_Sahoo)\
**Post date:** [May 26, 2025, 5:10am UTC](https://forum.scylladb.com/t/new-instance-of-aws-ami-scylladb-5-2-8-failed-to-start-scylla-server/4850/3 "2025-05-26T05:10:12Z")

</div>

I had to add developer\_mode: true in the scylla.yaml to up the server .
