# High Payload Size issue

**URL:** <https://forum.scylladb.com/t/high-payload-size-issue/4648>\
**Category:** ScyllaDB\
**Tags:** data-model, performance, memory\
**Created:** [March 24, 2025, 2:34pm UTC](https://forum.scylladb.com/t/high-payload-size-issue/4648 "2025-03-24T14:34:03Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![shock7221](https://sea2.discourse-cdn.com/flex016/user_avatar/forum.scylladb.com/shock7221/32/1592_2.png) [@shock7221](https://forum.scylladb.com/u/shock7221)\
**Post date:** [March 24, 2025, 2:34pm UTC](https://forum.scylladb.com/t/high-payload-size-issue/4648/1 "2025-03-24T14:34:03Z")

</div>

_Installation details_  
#ScyllaDB version: 6.1.2-0.20240915.b60f9ef4c223  
#Cluster size: 3 nodes  
#os (RHEL/CentOS/Ubuntu/AWS AMI): Ubuntu

Our payload size is around 3 - 5 kb.

 ![Screenshot 2025-03-24 at 10.34.29 AM](https://us1.discourse-cdn.com/flex016/uploads/scylladb/original/2X/a/aa32708cade12f148e6c5f8aa9a95019fccd5a6d.jpeg)

Is there anything we could do to lower the payload size? What are some potential issues it could cause? Could that cause memory issue because we saw in our older cluster it kept getting this error:

```auto
Mar 19 21:57:47 scylla-node-01 scylla[6060]: [shard 12:main] table - failed to write sstable /var/lib/scylla/data/<keyspace>/logs-44fb69b0ca2611efb3b9235c7d5cb03f/me-3gop_1p0b_0rv342wofndsn54rc1-big-Data.db: logalloc::bad_alloc (failed to refill emergency reserve of 30 (have 26 free segments))
Mar 19 21:57:47 scylla-node-01 scylla[6060]: [shard 12:main] table - Memtable flush failed due to: logalloc::bad_alloc (failed to refill emergency reserve of 30 (have 26 free segments)). Will retry in 10000ms
Mar 19 21:57:47 scylla-node-01 scylla[6060]: [shard 12:main] table - failed to write sstable /var/lib/scylla/data/<keyspace>/log_details-44619ab0ca2611efb3b9235c7d5cb03f/me-3gop_1p0b_5jbxc2wofndsn54rc1-big-Data.db: logalloc::bad_alloc (failed to refill emergency reserve of 30 (have 26 free segments))
Mar 19 21:57:47 scylla-node-01 scylla[6060]: [shard 12:main] table - Memtable flush failed due to: logalloc::bad_alloc (failed to refill emergency reserve of 30 (have 26 free segments)). Will retry in 10000ms
Mar 19 21:57:49 scylla-node-01 scylla[6060]: [shard 12:main] table - failed to w

```

---

<div class="post-metadata">

**Author:** ![Botond\_Denes](https://sea2.discourse-cdn.com/flex016/user_avatar/forum.scylladb.com/botond_denes/32/163_2.png) [@Botond\_Denes](https://forum.scylladb.com/u/Botond_Denes)\
**Post date:** [March 26, 2025, 11:59am UTC](https://forum.scylladb.com/t/high-payload-size-issue/4648/2 "2025-03-26T11:59:04Z")

</div>

The memory allocation failures are unrelated to the payload size. Rows or even cells which are 3-5KiB are considered to be of perfectly reasonable size.

The memory errors are caused by something else, I cannot tell just based on these logs.
