# Adding a cluster using sctool and using backup, getting "ERROR (deduplicating the snapshot)"

**URL:** https://forum.scylladb.com/t/adding-a-cluster-using-sctool-and-using-backup-getting-error-deduplicating-the-snapshot/4608
**Category:** Kubernetes Operator
**Tags:** error-message, scylla-manager, backup-restore, sctool
**Created:** [March 16, 2025, 4:49am UTC](https://forum.scylladb.com/t/adding-a-cluster-using-sctool-and-using-backup-getting-error-deduplicating-the-snapshot/4608 "2025-03-16T04:49:41Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Guy](https://sea2.discourse-cdn.com/flex016/user_avatar/forum.scylladb.com/guy/32/9_2.png) [@Guy](https://forum.scylladb.com/u/Guy)
#### Post date: [March 16, 2025, 4:49am UTC](https://forum.scylladb.com/t/adding-a-cluster-using-sctool-and-using-backup-getting-error-deduplicating-the-snapshot/4608/1 "2025-03-16T04:49:41Z")

</div>

> [@](#):
>
> [**Originally from the User Slack**](https://scylladb-users.slack.com/)
> 
> ![Pritam_Nagar](https://us1.discourse-cdn.com/flex016/uploads/scylladb/original/2X/c/c423e3b75402ca7afdd40a4da04c054372d59eba.png) **@Pritam\_Nagar:** @Kacper_Rzetelski hey, i’,m using scylla in gke after adding a cluster using
> 
> ```auto
> sctool cluster add ....
> 
> ```
> 
> when i schedule a backup the. very first backup is goes successfully but second one gives error
> 
> ```auto
> Status: ERROR (deduplicating the snapshot)
> Cause: deduplicate
> 10.80.4.23: delete deduplicated files: delete paths: agent [HTTP 404] Not found 
> 
> ```
> 
> i’m stuck over here please let me know if any one of you know the solution
> 
> ![Kacper_Rzetelski](https://us1.discourse-cdn.com/flex016/uploads/scylladb/original/2X/9/94552d3f2425b00e173150446eedfb5360245248.jpeg) **@Kacper_Rzetelski:** Hi, clusters added to SM directly through sctool won’t be controlled by the operator. Any clusters created with operator should automatically be registered with SM. For backup scheduling see [https://operator.docs.scylladb.com/stable/architecture/manager.html](https://operator.docs.scylladb.com/stable/architecture/manager.html). If you have issues with how to register a cluster with SM or schedule a backup through the operator, feel free to create an issue with must-gather attached so we can verify it.
> 
> As for the deduplication error from SM - I’m afraid I won’t be able to help here, try asking on scylla-manager channel.

---

<div class="post-metadata">

### Author: ![Michal\_Leszczynski](https://sea2.discourse-cdn.com/flex016/user_avatar/forum.scylladb.com/michal_leszczynski/32/429_2.png) [@Michal\_Leszczynski](https://forum.scylladb.com/u/Michal_Leszczynski)
#### Post date: [March 17, 2025, 8:31am UTC](https://forum.scylladb.com/t/adding-a-cluster-using-sctool-and-using-backup-getting-error-deduplicating-the-snapshot/4608/2 "2025-03-17T08:31:11Z")

</div>

Hi, could you share logs and version (both for both scylla-manager and scylla-manager-agents)?

My suspicion is that you updated scylla-manager server, but you forgot to update scylla-manager-agents, so scylla-manager is trying to query endpoints, which were not exposed in the previous versions, and that causes the error.

---

<div class="post-metadata">

### Author: ![Pritam\_Nagar](https://sea2.discourse-cdn.com/flex016/user_avatar/forum.scylladb.com/pritam_nagar/32/1636_2.png) [@Pritam\_Nagar](https://forum.scylladb.com/u/Pritam_Nagar)
#### Post date: [April 15, 2025, 1:12pm UTC](https://forum.scylladb.com/t/adding-a-cluster-using-sctool-and-using-backup-getting-error-deduplicating-the-snapshot/4608/3 "2025-04-15T13:12:21Z")

</div>

I got fixed when i update the versions of scylla and scylla manager(5.2.x --\>6.2.0).

And schedule the backup it works fine for some days and got error of file indexing just like this issue:
